Papinou Demo-Skins

[fr]  Home  Blog  News  Links  FAQ  Guestbook  Forum
Update

Upgrade

You now have a running GuppY but you feel like upgrading it. What you must understand in the first place is how the different versions of GuppY have been named.

A Guppy version is identified by five numbers, e.g. 5.01.07. The first three digits indicate the main version of Guppy whereas the third one is the corrective patch number of the main version.

In 5.01.07, main version is 5.01 and this version holds 07 corrections of the main version.

When upgrading, you will have to make a choice: either your Guppy is already running on the last version available, or it is a previous version. In the former case, you have to add a patch to your running GuppY, and in the latter, you'll have to migrate from the old version of GuppY to the latest one.
 

Upgrade from the same main version (applying the latest patch)

Your GuppY is already in the 5.01.xx version (x < 07) and you want to upgrade. To achieve this, you can download patches on Freeguppy. (https://www.freeguppy.org/). And again there are two cases: either your Guppy is in the previous version (for instance 5.01.06 to be upgraded to 5.01.07), or it is in an older version (5.01.01 with x range from 00 to 11included).

Installation with Installer

Once relevant zip archive of the patch has been downloaded, go to Admin, then general Management and Install.

Click  "Browse" to choose zip archive, another click to lozd the file and a last one to install.

And you're done; tour site has been patched in the latest version of GuppY.

Attention: if your hoster restrains upload_max_filesize function to 2M for instance, you might not being able to use function "Install"  zip archivesexceeding 2Mo.

You will then have to ask your hoster to increase it up to 10M for instance. With Free, which still restrains at 2M, your request will probably be ignored.
 

Upgrade from a previous main version (migration)


Important : the migration script is intended for websites running with version 4.6.x of GuppY.

The evolution of version 5 is so substantial that it was not possible to provide a migration from older versions .

If your website runs on an older version of GuppY, you will have to first migrate to 4.6.28 before doing it to 5.03.XX.


Creation date : 26/04/2017 : 17:29
Last update : 26/04/2017 : 17:29
Category : GuppY
Page read 362 times
Top

Valid HTML 5.0 freeguppy.org © 2004-2020 More info ... Valid CSS 3
Skins Papinou GuppY 5    Licence Libre CeCILL